
Computers/Technology Learning Goals 

 

A. Kindergarten 
a. Mouse Skills-Students will be able to... 

i. hold a mouse. 
ii. use a mouse. 

iii. click using a mouse. 
iv. double-click using a mouse. 
v. click and drag using a mouse.  

b. Equipment-Students will be able to... 
i. identify the different parts of the computer. 

1. Monitor/Screen 
2. Computer Processing Unit(CPU)/Brain 
3. Headphones 
4. Mouse 
5. Keyboard 

ii. use headphones. 
iii. use a keyboard. 
iv. turn on the monitor. 

c. Keyboarding-Students will be able to... 
i. identify the letters on the keyboard. 

ii. identify the numbers on the keyboard. 
iii. capitalize letters using the SHIFT key. 
iv. use ENTER. 
v. use BACKSPACE. 

vi. use SPACEBAR. 
d. Internet-Students will be able to... 

i. navigate website(s). 
ii. close the webpage(s). 

iii. maximize their webpage. 
e. Windows-Students will be able to... 

i. locate the desktop. 
ii. locate the taskbar. 

iii. identify the WINDOWS symbol. 
iv. locate specific icons. 

f. Paint-Students will be able to... 
i. illustrate a picture. 

ii. use the toolbars. 
1. Shapes 
2. Colors 
3. Brushes 
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B. 1st Grade 
a. Mouse Skills-Students will be able to... 

i. hold a mouse. 
ii. use a mouse. 

iii. click using a mouse. 
iv. double-click using a mouse. 
v. click and drag using a mouse.  

b. Equipment-Students will be able to... 
i. identify the different parts of the computer. 

1. Monitor/Screen 
2. Computer Processing Unit(CPU)/Brain 
3. Headphones 
4. Mouse 
5. Keyboard 

ii. use headphones. 
iii. use a keyboard. 
iv. turn on the monitor. 
v. log-on/sign-off. 

vi. turn computer on/off. 
c. Keyboarding-Students will be able to... 

i. identify/use the letters on the keyboard. 
ii. identify/use the numbers on the keyboard. 

iii. capitalize a letter using the SHIFT key. 
iv. capitalize multiples letters using the CAPS LOCK key.  
v. use ENTER. 

vi. use BACKSPACE. 
vii. use SPACEBAR. 

viii. locate home row keys.  
d. Internet-Students will be able to... 

i. navigate website(s). 
ii. close the webpage(s). 

iii. maximize their webpage. 
iv. minimize their webpage. 
v. navigate between multiple open tabs. 

vi. use the back button. 
e. Windows-Students will be able to... 

i. locate the desktop. 
ii. locate the taskbar. 

iii. identify the WINDOWS symbol. 
iv. locate specific icons. 
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v. search programs/applications. 
f. Paint-Students will be able to... 

i. illustrate a picture. 
ii. use the toolbars. 

1. Shapes 
2. Colors 
3. Brushes 

g. Word Processing-Students will be able to... 
i. use the File Tab features. 

1. Save 
2. Print 

ii. use the Home Tab features. 
1. Font Group 

a. Size 
b. Style 
c. Color 
d. Bold, italics, underline 

h. Digital Citizenship-Students will be able to... 
i. use the internet safely. 

C. 2nd Grade 
a. Mouse Skills-Students will be able to... 

i. hold a mouse. 
ii. use a mouse. 

iii. click using a mouse. 
iv. double-click using a mouse. 
v. click and drag using a mouse.  

b. Equipment-Students will be able to... 
i. identify the different parts of the computer. 

1. Monitor/Screen 
2. Computer Processing Unit(CPU)/Brain 
3. Headphones 
4. Mouse 
5. Keyboard 

ii. use headphones. 
iii. use a keyboard. 
iv. turn on/off the monitor. 
v. log-on/sign-off. 

vi. turn computer on/off. 
c. Keyboarding-Students will be able to... 

i. identify/use the letters on the keyboard. 
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ii. identify/use the numbers on the keyboard. 
iii. capitalize a letter using the SHIFT key. 
iv. capitalize multiples letters using the CAPS LOCK key.  
v. use ENTER. 

vi. use BACKSPACE. 
vii. use SPACEBAR. 

viii. locate home row keys.  
ix. identify the home row keys. 

d. Internet-Students will be able to... 
i. navigate website(s). 

ii. close the webpage(s). 
iii. maximize their webpage. 
iv. minimize their webpage. 
v. navigate between multiple open tabs. 

vi. use the back button. 
vii. search online pictures. 

e. Windows-Students will be able to... 
i. locate the desktop. 

ii. locate the taskbar. 
iii. identify the WINDOWS symbol. 
iv. locate specific icons. 
v. search programs/applications. 

f. Paint-Students will be able to... 
i. illustrate a picture. 

ii. use the toolbars. 
1. Shapes 
2. Colors 
3. Brushes 

iii. insert image. 
iv. format image. 

g. Word Processing-Students will be able to… 
i. create a basic document using Microsoft Word. 

ii. use the File Tab features. 
1. Save/Save As 
2. Print 

iii. use the Home Tab features. 
1. Clipboard Group 

a. Copy 
b. Cut 
c. Paste 
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2. Font Group 
a. Size 
b. Style 
c. Color 
d. Bold, italics, underline, strikethrough, subscript, 

superscript 
3. Insert 

a. Alignment-left, center, right 
b. Bullets 
c. Numbering 

iv. use the Insert Tab features. 
1. Table Group 

a. Table 
2. Illustration group 

a. Pictures-Online Pictures/Clip Art 
v. use the Design Tab features. 

1. Page Background Group 
a. Page Color 
b. Page Border 

vi. use the Page Layout features. 
1. Page Setup Group 

a. Orientation 
b. Columns 

h. Digital Citizenship-Students will be able to... 
i. use the internet safely. 

D. 3rd Grade 
a. Mouse Skills-Students will be able to... 

i. use a mouse effortlessly. 
b. Equipment-Students will be able to... 

i. identify the different parts of the computer. 
ii. use all parts of a computer. 

c. Keyboarding-Students will be able to... 
i. further develop keyboard fluency. 

ii. identify all symbols on the keyboard. 
d. Internet-Students will be able to... 

i. navigate website(s). 
ii. close the webpage(s). 

iii. maximize their webpage. 
iv. minimize their webpage. 
v. navigate between multiple open tabs. 



Computers/Technology Learning Goals 

vi. use the back button. 
e. Windows-Students will be able to... 

i. locate the desktop. 
ii. locate the taskbar. 

iii. identify the WINDOWS symbol. 
iv. locate specific icons. 
v. search programs/applications. 

f. Graphics-Students will be able to... 
i. illustrate using the Paint Program. 

ii. search online pictures. 
iii. get pictures from ClipArt. 
iv. format image(s). 
v. insert images. 

g. Word Processing-Students will be able to… 
i. create a document using Microsoft Word. 

ii. use the File Tab features. 
1. Save/Save As 
2. Print 

iii. use the Home Tab features. 
1. Clipboard Group 

a. Copy 
b. Cut 
c. Paste 

2. Font Group 
a. Size 
b. Style 
c. Color 
d. Bold, italics, underline, strikethrough, subscript, 

superscript 
e. Highlight 
f. Format 
g. Change Case 

3. Insert 
a. Alignment-left, center, right 
b. Bullets 
c. Numbering 
d. Indent 
e. Header/Footer 
f. Text Box 

iv. use the Insert Tab features. 
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1. Table Group 
a. Table 

2. Illustration group 
a. Pictures-Online Pictures/Clip Art 
b. Shapes 

v. use the Design Tab features. 
1. Page Background Group 

a. Page Color 
b. Page Border 

vi. use the Page Layout features. 
1. Page Setup Group 

a. Orientation 
b. Margins 
c. Columns 

2. Paragraph Group 
a. Indent 

vii. use the Review Tab. 
1. Spell Check 

h. Digital Citizenship-Students will be able to... 
i. use the internet safely. 

i. Presentations-Students will be able to... 
i. create a simple slideshow with text and graphics. 

j. Coding-Students will be able to... 
i. understand the basics of coding. 

E. 4th Grade 
a. Mouse Skills-Students will be able to... 

i. use a mouse effortlessly. 
b. Equipment-Students will be able to... 

i. identify the different parts of the computer. 
ii. use all parts of a computer. 

c. Keyboarding-Students will be able to... 
i. further develop keyboard fluency. 

ii. identify all symbols on the keyboard. 
d. Internet-Students will be able to... 

i. navigate website(s). 
ii. close the webpage(s). 

iii. maximize their webpage. 
iv. minimize their webpage. 
v. navigate between multiple open tabs. 

vi. use the back button. 
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e. Windows- Students will be able to... 
i.  locate the desktop. 

ii.  locate the taskbar. 
iii. identify the WINDOWS symbol. 
iv. locate specific icons. 
v. search programs/applications. 

f. Graphics- Students will be able to... 
i. illustrate using the Paint Program. 

ii. search online pictures. 
iii. get pictures from ClipArt. 
iv. format image(s). 
v. insert image(s). 

g. Word Processing- Students will be able to… 
i. create a document using Microsoft Word. 

ii. use the File Tab features. 
1. Save/Save As 
2. Print 

iii. use the Home Tab features. 
1. Clipboard Group 

a. Copy 
b. Cut 
c. Paste 

2. Font Group 
a. Size 
b. Style 
c. Color 
d. Bold, italics, underline, strikethrough, subscript, 

superscript 
e. Highlight 
f. Format 
g. Change Case 

3. Paragraph group 
a. Alignment-left, center, right 
b. Bullets 
c. Numbering 
d. Indent 
e. Header/Footer 
f. Text Box 

iv. use the Insert Tab features. 
1. Table Group 



Computers/Technology Learning Goals 

a. Table 
2. Illustration group 

a. Pictures-Online Pictures/Clip Art 
b. Shapes 

v. use the Design Tab features. 
1. Page Background Group 

a. Page Color 
b. Page Border 

vi. use the Page Layout features. 
1. Page Setup Group 

a. Orientation 
b. Margins 
c. Columns 

2. Paragraph Group 
a. Indent 

vii. use the Review Tab. 
1. Spell Check 

h. Digital Citizenship- Students will be able to... 
i. use the internet safely. 

i. Presentations- Students will be able to... 
i. create a simple slideshow with text, graphics, animations and 

transitions. 
j. Coding-  Students will be able to... 

i. work with coding. 
k. Spreadsheet- Students will be able to... 

i. create a simple graph using Microsoft Excel. 
l. Research- Students will be able to... 

i. conduct search using the internet. 
ii. collect resources. 

iii. collect information for given topic. 
F. 5th Grade 

a. Keyboarding- Students will be able to... 
i. use Home Row keys to type. 

ii. continue to learn correct form of touch typing.  
b. Internet- Students will be able to... 

i. use various websites. 
ii. navigate by choosing links and menus. 

c. Graphics- Students will be able to... 
i. find and insert image. 

ii. format image.  
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iii. use snipping tool. 
d. Word Processing- Students will be able to… 

i. create a document using Microsoft Word. 
ii. use the File Tab features. 

1. Save/Save As 
2. Print 

iii. use the Home Tab features. 
1. Clipboard Group 

a. Copy 
b. Cut 
c. Paste 

2. Font Group 
a. Size 
b. Style 
c. Color 
d. Bold, italics, underline, strikethrough, subscript, 

superscript 
e. Highlight 
f. Format 
g. Change Case 

3. Paragraph Group 
a. Alignment-left, center, right 
b. Bullets 
c. Numbering 
d. Indent 
e. Header/Footer 
f. Text Box 

iv. use the Insert Tab features. 
1. Table Group 

a. Table 
2. Illustration group 

a. Pictures-Online Pictures/Clip Art 
b. Shapes 

v. use the Design Tab features. 
1. Page Background Group 

a. Page Color 
b. Page Border 

vi. use the Page Layout features. 
1. Page Setup Group 

a. Orientation 
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b. Margins 
c. Columns 

2. Paragraph Group 
a. Indent 

vii. use the Review Tab. 
1. Spell Check 

e. Digital Citizenship- Students will be able to... 
i. use digital etiquette when on websites. 

ii. understand digital footprint. 
iii. use safe internet practices. 

f. Presentations- Students will be able to... 
i. create slideshow using text, graphics, themes, animation and 

transitions. 
ii. use the Home Tab features. 

1. Slides 
a. Insert/delete a slide 
b. Slide format 

2. Font 
a. All font features 

3. Paragraph 
a. Alignment-left, center, right 

iii. use the Insert Tab features. 
1. Images 

a. Picture-ClipArt/Online picture 
2. Text 

a. Text Box 
b. Word Art 

iv. Use the Design Tab features. 
1. Choose a slide design 

v. use the Transition Tab features. 
1. Add a transition to each slide 

vi. use the Animation Tab features. 
1. Add an animation for text box(es) and image(s)  

vii. view Slide Show. 
g. Coding- Students will be able to... 

i. work through various coding activities. 
ii. participate in “An Hour of Code” on www.code.org. 

h. Spreadsheet-Students will be able to... 
i. use the File Tab features. 

1. File 

http://www.code.org/
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2. Save/Save As 
ii. use the Home Tab features. 

1. Font Group 
a. All font features 

2. Alignment Group 
a. Alignment-left, center, right 

3. Cell Group 
a. insert/delete cells 

iii. use the Insert Tab features. 
1. Tables 
2. Charts 

iv. use Formula Tab features. 
1. Basic formula 

i. Research-Students will be able to… 
i. conduct search using the internet. 

ii. collect resources. 
iii. collect information for given topic. 
iv. understand the difference between .edu, .gov, .org 

j. Publisher-Students will be able to… 
i. find and use templates. 

G. 6th Grade- 
a. Keyboarding- Students will be able to... 

i. use Home Row keys to type. 
ii. continue to learn correct form of touch typing.  

b. Internet- Students will be able to... 
i. use various websites. 

ii. navigate by choosing links and menus. 
c. Graphics- Students will be able to... 

i. find and insert image. 
ii. format image.  

iii. use snipping tool. 
iv. save picture as a picture file. 
v. Fill bucket.  

d. Word Processing- Students will be able to… 
i. create a document using Microsoft Word. 

ii. use the File Tab features. 
1. Save/Save As 
2. Print 

iii. use the Home Tab features. 
1. Clipboard Group 
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a. Copy 
b. Cut 
c. Paste 

2. Font Group 
a. Size 
b. Style 
c. Color 
d. Bold, italics, underline, strikethrough, subscript, 

superscript 
e. Highlight 
f. Format 
g. Change Case 

3. Paragraph Group 
a. Alignment-left, center, right 
b. Bullets 
c. Numbering 
d. Indent 
e. Header/Footer 
f. Text Box 

iv. use the Insert Tab features. 
1. Table Group 

a. Table 
2. Illustration group 

a. Pictures-Online Pictures/Clip Art 
b. Shapes 

v. use the Design Tab features. 
1. Page Background Group 

a. Page Color 
b. Page Border 

vi. use the Page Layout features. 
1. Page Setup Group 

a. Orientation 
b. Margins 
c. Columns 

2. Paragraph Group 
a. Indent 
b. Line spacing  

vii. use the Review Tab. 
1. Spell Check 

e. Digital Citizenship- Students will be able to... 
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i. use digital etiquette when on websites. 
ii. understand digital footprint. 

iii. use safe internet practices. 
f. Presentations- Students will be able to... 

i. create slideshow using text, graphics, themes, animation and 
transitions. 

ii. use the Home Tab features. 
1. Slides 

a. Insert/delete a slide 
b. Slide format 

2. Font 
a. All font features 

3. Paragraph 
a. Alignment-left, center, right 

iii. use the Insert Tab features. 
1. Images 

Picture-ClipArt/Online picture 
2. Text 

a. Text Box 
b. Word Art 

iv. Use the Design Tab was the features. 
1. Choose a slide design 

v. use the Transition Tab features. 
1. Add a transition to each slide 

vi. use the Animation Tab features. 
1. Add an animation for text box(es) and image(s)  

vii. view Slide Show. 
g. Coding- Students will be able to... 

i. work through various coding activities. 
ii. participate in “An Hour of Code” on www.code.org. 

h. Spreadsheet-Students will be able to… 
i. add data to spreadsheet. 

ii. make graphs. 
iii. identify cell references.  
iv. use the File Tab features. 

1. File 
2. Save/Save As 

v. use the Home Tab features. 
1. Font Group 

a. All font features 

http://www.code.org/
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b. Add color to cell 
2. Alignment Group 

a. Alignment-left, center, right 
3. Cell Group 

a. insert/delete cells 
vi. use the Insert Tab features. 

1. Tables 
2. Charts 

vii. use Formula Tab features. 
1. Basic formula 

i. Research-Students will be able to… 
i. conduct search using the internet. 

ii. collect resources. 
iii. collect information for given topic. 
iv. understand the difference between .edu, .gov, .org. 

j. Publisher-Students will be able to… 
i. find and use templates. 

H. 7th Grade- Students will be able to... 
a. Keyboarding- Students will be able to... 

i. use Home Row keys to type. 
ii. continue to learn correct form of touch typing.  

iii. type at least 25 words per minute (WPM). 
b. Internet- Students will be able to... 

i. use various websites. 
ii. navigate by choosing links and menus. 

iii. add shortcuts to the desktop. 
c. Graphics- Students will be able to... 

i. find and insert image. 
ii. format image.  

1. Rotate an image 
iii. use snipping tool. 
iv. save picture as a picture file. 
v. Fill bucket.  

d. Word Processing- Students will be able to… 
i. create a document using Microsoft Word. 

ii. use the File Tab features. 
1. Save/Save As 
2. Print 

iii. use the Home Tab features. 
1. Clipboard Group 
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a. Copy 
b. Cut 
c. Paste 

2. Font Group 
a. Size 
b. Style 
c. Color 
d. Bold, italics, underline, strikethrough, subscript, 

superscript 
e. Highlight 
f. Format 
g. Change Case 

3. Paragraph Group 
a. Alignment-left, center, right 
b. Bullets 
c. Numbering 
d. Indent 
e. Header/Footer 
f. Text Box 

iv. use the Insert Tab features. 
1. Table Group 

a. Table 
2. Illustration group 

a. Pictures-Online Pictures/Clip Art 
b. Shapes 

v. use the Design Tab features. 
1. Page Background Group 

a. Page Color 
b. Page Border 

vi. use the Page Layout features. 
1. Page Setup Group 

a. Orientation 
b. Margins 
c. Columns 

2. Paragraph Group 
a. Indent 
b. Line spacing  

vii. use the Review Tab. 
1. Spell Check 

e. Digital Citizenship- Students will be able to... 
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i. use digital etiquette when on websites. 
ii. understand digital footprint. 

iii. use safe internet practices. 
f. Presentations- Students will be able to... 

i. create slideshow using text, graphics, themes, animation and 
transitions. 

ii. use the Home Tab features. 
1. Slides 

a. Insert/delete a slide 
b. Slide format 

2. Font 
a. All font features 

3. Paragraph 
a. Alignment-left, center, right 

iii. use the Insert Tab features. 
1. Images 

a. Picture-ClipArt/Online picture 
2. Text 

a. Text Box 
b. Word Art 

iv. Use the Design Tab features. 
1. Choose a slide design 

v. use the Transition Tab features. 
1. Add a transition to each slide 

vi. use the Animation Tab features. 
1. Add an animation for text box(es) and image(s)  

vii. view Slide Show. 
g. Coding- Students will be able to... 

i. work through various coding activities. 
ii. participate in “An Hour of Code” on www.code.org. 

iii. create project on www.scratch.mit.edu. 
h. Spreadsheet-Students will be able to… 

i. collect/add data to spreadsheet. 
ii. make various graphs. 

iii. identify cell references.  
iv. use spreadsheets to analyze data. 
v. use the File Tab features. 

1. File 
2. Save/Save As 

vi. use the Home Tab features. 

http://www.code.org/
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1. Font Group 
a. All font features 
b. Add color to cell 

2. Alignment Group 
a. Alignment-left, center, right 

3. Cell Group 
a. insert/delete cells 

vii. use the Insert Tab features. 
1. Tables 
2. Illustrations 

a. ClipArt/Online pictures 
3. Charts 

viii. use Formula Tab features. 
1. formulas 

i. Research-Students will be able to… 
i. conduct search using the internet. 

ii. collect resources. 
iii. collect information for given topic. 
iv. understand the difference between .edu, .gov, .org. 
v. ethically use website and information  

j. Publisher-Students will be able to… 
i. find and use templates. (cards, newsletters, calendars, fliers, etc.) 

I. 8th Grade- Students will be able to... 
a. Keyboarding- Students will be able to... 

i. use Home Row keys to type. 
ii. continue to learn correct form of touch typing.  

iii. type at least 30 words per minute (WPM). 
b. Internet- Students will be able to... 

i. use various websites. 
ii. navigate by choosing links and menus. 

iii. add shortcuts to the desktop. 
c. Graphics- Students will be able to... 

i. find and insert image. 
ii. format image.  

1. Rotate an image 
iii. use snipping tool. 
iv. save picture as a picture file. 
v. Fill bucket.  

d. Word Processing- Students will be able to… 
i. create a document using Microsoft Word. 
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ii. use the File Tab features. 
1. Save/Save As 
2. Print 

iii. use the Home Tab features. 
1. Clipboard Group 

a. Copy 
b. Cut 
c. Paste 

2. Font Group 
a. Size 
b. Style 
c. Color 
d. Bold, italics, underline, strikethrough, subscript, 

superscript 
e. Highlight 
f. Format 
g. Change Case 

3. Paragraph Group 
a. Alignment-left, center, right 
b. Bullets 
c. Numbering 
d. Indent 
e. Header/Footer 
f. Text Box 

iv. use the Insert Tab features. 
1. Table Group 

a. Table 
2. Illustration group 

a. Pictures-Online Pictures/Clip Art 
b. Shapes 

v. use the Design Tab features. 
1. Page Background Group 

a. Page Color 
b. Page Border 

vi. use the Page Layout features. 
1. Page Setup Group 

a. Orientation 
b. Margins 
c. Columns 

2. Paragraph Group 
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a. Indent 
b. Line spacing  

vii. use the Review Tab. 
1. Spell Check 

e. Digital Citizenship- Students will be able to... 
i. use digital etiquette when on websites. 

ii. understand digital footprint. 
iii. use safe internet practices. 

f. Presentations- Students will be able to... 
i. create slideshow using text, graphics, themes, animation and 

transitions. 
ii. use the Home Tab features. 

1. Slides 
a. Insert/delete a slide 
b. Slide format 

2. Font 
a. All font features 

3. Paragraph 
a. Alignment-left, center, right 

iii. use the Insert Tab features. 
1. Images 

a. Picture-ClipArt/Online picture 
2. Text 

a. Text Box 
b. Word Art 

iv. Use the Design Tab features. 
1. Choose a slide design 

v. use the Transition Tab features. 
1. Add a transition to each slide 

vi. use the Animation Tab features. 
1. Add an animation for text box(es) and image(s). 
2. Add timing  

vii. view Slide Show. 
g. Coding- Students will be able to... 

i. work through various coding activities. 
ii. participate in “An Hour of Code” on www.code.org. 

iii. create project on www.scratch.mit.edu. 
h. Spreadsheet-Students will be able to… 

i. collect/add data to spreadsheet. 
ii. make various graphs. 

http://www.code.org/
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iii. identify cell references.  
iv. use spreadsheets to analyze data. 
v. use the File Tab features. 

1. File 
2. Save/Save As 

vi. use the Home Tab features. 
1. Font Group 

a. All font features 
b. Add color to cell 

2. Alignment Group 
a. Alignment-left, center, right 

3. Cell Group 
a. insert/delete cells 

vii. use the Insert Tab features. 
1. Tables 
2. Illustrations 

a. ClipArt/Online pictures 
3. Charts 

viii. use Formula Tab features. 
1. formulas 

i. Research-Students will be able to… 
i. conduct search using the internet. 

ii. collect resources. 
iii. collect information for given topic. 
iv. understand the difference between .edu, .gov, .org. 
v. ethically use website and information  

j. Publisher-Students will be able to… 
i. find and use templates. (cards, newsletters, calendars, fliers, etc.) 


